problemi con il PGL

#1
ciao a tutti spero di aver azzeccato il posto giusto per la mia conversazione.

Come dice il titolo ho un problema con il PGL praticamente accedo alla pagina principale dove mi chiede che lingua selezionare, metto italiano e automaticamente si apre un altra pagina (che credo sia l'effettiva home page del sito) dove teoricamente c'è tutto il PGL.

Ecco, il mio problema è che quella pagina (la home page) non si carica cioè non è che il motore di ricerca carica all'infinito, ma si blocca praticamente subito come se avesse effettivamente aperto la pagina, solo che non l'ha fatto.

Ho già provato a cambiare motore di ricerca ma senza nessun risultato! aiutatemi 
 
 
 
 
 
 
 
#2
ciao a tutti spero di aver azzeccato il posto giusto per la mia conversazione.

Come dice il titolo ho un problema con il PGL praticamente accedo alla pagina principale dove mi chiede che lingua selezionare, metto italiano e automaticamente si apre un altra pagina (che credo sia l'effettiva home page del sito) dove teoricamente c'è tutto il PGL.

Ecco, il mio problema è che quella pagina (la home page) non si carica cioè non è che il motore di ricerca carica all'infinito, ma si blocca praticamente subito come se avesse effettivamente aperto la pagina, solo che non l'ha fatto.

Ho già provato a cambiare motore di ricerca ma senza nessun risultato! aiutatemi 
 
 
 
 
 
 
Pazienta ancora, clicca qua e là, pazienta ancora.

A me va in questo modo
 
#3
Hai provato ad aspettare 15-20 secondi? Perché la pagina è molto pesante e ci mette un po' a caricarla anche se il browser ha finito di caricare 

Poi hai estensioni che bloccano la pubblicità? Come adblock. Se sì devi autorizzare quel sito ad adblock perché è lui che ti impedisce di visualizzarla